Home
Insightful &
Helpful Articles

Here is what we're working on and
thinking at Hedgehog security.

Age in Days
CVSS Score
Patch within next
Risk Level

2311


10.0

30 Days

Critical

 

This vulnerability is 6 years 3 months and 28 days old there are exploits publicly available for it. The vulnerability itself is over a year old, and with there being exploits publicly available it is highly advisable that this vulnerability is patched immediately.

 

Synopsis

The remote web server uses a version of PHP that is affected by multiple vulnerabilities.

 

Vulnerability Description

According to its banner, the version of PHP installed on the remote host is 5.3.x earlier than 5.3.15, and is, therefore, potentially affected by the following vulnerabilities:

  • An unspecified overflow vulnerability exists in the function '_php_stream_scandir' in the file 'main/streams/streams.c'. (CVE-2012-2688)
  • An unspecified error exists that can allow the 'open_basedir' constraint to be bypassed. (CVE-2012-3365)

 

Solution

Upgrade to PHP version 5.3.15 or later.

 

Further Information

 

CVE References

CVE-2012-2688 NIST | MITRE | CVEDetails
CVE-2012-3365 NIST | MITRE | CVEDetails

 

Get in touch

Should you have any questions regarding this or any security matter, please do not hesitate to get in touch by emailing the Hedgehog Cyber Operations Team.

Whilst every effort is made to ensure the accuracy and robustness of any information presented, it is not possible for Hedgehog Cyber to test every possible scenario an organisation may face, and Hedgehog Cyber cannot be held liable for any loss or damage which may arise from taking action on any of the contents provided. Hedgehog Cyber strongly advises that all recommendations, solutions and detection methods detailed, are thoroughly reviewed and tested in non-production environments before being considered suitable for production release, in-line with any existing internal change control procedures.