This vulnerability is 6 years 9 months and 10 days old there are exploits publicly available for it. The vulnerability itself is over a year old, and with there being exploits publicly available it is highly advisable that this vulnerability is patched immediately.
SynopsisThe remote Samba server is affected by multiple buffer overflow vulnerabilities.
Vulnerability DescriptionAccording to its banner, the version of Samba 3.x running on the remote host is earlier than 3.6.4 / 3.5.14 / 3.4.16. It is, therefore, affected by multiple heap-based buffer overflow vulnerabilities.
An error in the DCE/RPC IDL (PIDL) compiler causes the RPC handling code it generates to contain multiple heap-based buffer overflow vulnerabilities. This generated code can allow a remote, unauthenticated attacker to use malicious RPC calls to crash the application and possibly execute arbitrary code as the root user.
Note that us has not actually tried to exploit this issue or otherwise determine if one of the associated patches has been applied.
SolutionEither install the appropriate patch referenced in the project's advisory or upgrade to 3.6.4 / 3.5.14 / 3.4.16 or later.
CVE ReferencesCVE-2012-1182 NIST | MITRE | CVEDetails
Get in touch
Should you have any questions regarding this or any security matter, please do not hesitate to get in touch by emailing the Hedgehog Cyber Operations Team.
Whilst every effort is made to ensure the accuracy and robustness of any information presented, it is not possible for Hedgehog Cyber to test every possible scenario an organisation may face, and Hedgehog Cyber cannot be held liable for any loss or damage which may arise from taking action on any of the contents provided. Hedgehog Cyber strongly advises that all recommendations, solutions and detection methods detailed, are thoroughly reviewed and tested in non-production environments before being considered suitable for production release, in-line with any existing internal change control procedures.